JAM Session

all the musical thrills without the musical skills

user's guide
Programming:  Steve Capps
              Neil Cormia
              Ty Roberts

Apple® IIgs® Version:  Neil Cormia

Musical Direction:  Ed Bogas

Product Manager:  Edward Badasov

Marketing Manager:  Latricia Turner

Program Graphics:  Avril Harrison

Manual:  Edward Badasov

Special Thanks to:  Todd Rundgren
              Brøderbund Quality Assurance Department
              Marge Boots
              David Kessler
              Will Naber
              Gene Portwood
              Neal Cavanaugh

© Copyright 1987, 1989 Brøderbund Software, Inc. 17 Paul Drive, San Rafael, California 94903-2101. All rights reserved.

Apple and Apple IIgs are registered trademarks of Apple Computer, Inc.
Radio Shack is a service mark of Tandy Corporation.
Jam Session is a trademark of Brøderbund Software, Inc.
Have you ever seen musicians get together and spontaneously create great sounding music, without even rehearsing ahead of time? Ever wished you could sit down and instantly play music just like the pros? With Jam Session you can do just that!

Using high-quality digitized instrument sounds in combination with music composed by professional songwriters, Jam Session sets you free to “cut loose” and play sizzling solos and melodic passages on a variety of instruments, while the program acts as a “backup” band for you.

You don’t have to worry about making mistakes, either! Jam Session automatically takes care of all chord changes and other nitty-gritty musical details, so you’ll never play a sour note. Although Jam Session prevents you from making mistakes, it doesn’t stifle your creativity. The special way in which the Jam Session songs are constructed leaves plenty of room for you to be the star of the show.

Jam Session also contains special features, such as a riff editor, that let you further expand your musical creativity. Above all, Jam Session is meant to be fun, so take a deep breath and get ready... it’s almost show time!
Getting Started

What You Will Need

An Apple IIgs with at least 768K of memory

Optional Equipment:
• A second disk drive
• External amplification (see below)
• Stereo card (see below)
• At least one blank formatted disk

External Amplification

All of the songs included in this program take full advantage of the sophisticated sound chip built into the Apple IIgs. As a result, Jam Session produces a very rich and authentic sound. However, the small speaker inside the IIgs cannot convey the entire frequency spectrum that the sound chip produces. To get the full benefit of Jam Session’s high-quality sound, it’s recommended that you use some form of external amplification (headphones, stereo, etc.) with the program.

It’s actually quite simple to hook-up your IIgs to an external sound system. At the back of your computer, you’ll find an external speaker jack with an icon below it that looks like a pair of headphones. This jack is a standard 1/8-inch phono jack to which you can connect headphones, external speakers, a stereo system or a portable cassette player. Connecting instructions are included below, and in cases where a connecting cable or adapter is required, a Radio Shack® part number has been included so you can easily obtain the necessary part.

Headphones with an 1/8-inch Plug: These headphones are typically the kind used with portable cassette players, and can be plugged directly into the IIgs phono jack. However, the IIgs only produces mono output, so music will only come out of one of the headphone speakers. If you want to hear music in both ears you should get an 1/8-inch MONO ADAPTER (Radio Shack part #274-368). Plug the adapter into the IIgs phono jack, and then plug the headphones into the adapter.

Headphones with a 1/4-inch Plug: These headphones have a large plug that typically fits a stereo receiver or tape deck. To connect these
headphones to the IIgs you will need to obtain a 1/4-inch STEREO TO 1/8-inch MONO ADAPTER (Radio Shack part #274-361A). Plug the adapter into the IIgs phono jack, and then plug the headphones into the adapter.

External Speakers: There is a variety of small to medium size speakers available that can plug directly into the IIgs phono jack. These speakers are available in mono (one speaker) or stereo (two speakers). If you get stereo speakers, you may also want to get an 1/8-inch MONO ADAPTER (Radio Shack part #274-368) so that the IIgs mono sound will play through both speakers.

Portable Cassette Player: To connect your IIgs to a portable cassette player, you will need a cable with two 1/8-inch plugs (Radio Shack part #42-2420). One end of the cable plugs into the IIgs 1/8-inch phono jack, and the other end plugs into your cassette player’s “AUX” input jack. If your cassette player does not have an “AUX” input jack, refer to the instruction manual for directions on how to feed external input into your cassette player.

Stereo Receiver: To connect your IIgs to your stereo you will need a cable with an 1/8-inch plug at one end and an RCA plug at the other end (Radio Shack part #42-2444). Plug the 1/8-inch plug into the IIgs phono jack, and the RCA plug into your stereo’s “AUX” input jack. (Consult the manual that came with your stereo for information on selecting auxiliary input.) You will also need to select Mono on your stereo so the music will play out of both speakers. If your stereo does not have a Mono selector and you would like to hear the music play through both speakers, you will need to get a cable that splits into two RCA plugs (Radio Shack part #42-2153).

Stereo Cards for the Apple IIgs: There are plug in cards available for the Apple IIgs that allow it to produce full stereo sound. Jam Session has been designed to take advantage of these cards. If you have one of these cards, please follow the instructions for the stereo card to find out how to connect it to a speaker system.
Mouse Review

If you are new to the Apple IIcs, you should read your User's Manual for information on the special features of the computer. This section quickly reviews the methods for using the mouse.

Click: 1. Position the pointer on an object. 2. Press and release the mouse button.

Drag: 1. Position the pointer on an object. 2. Press and hold the mouse button. 3. Move the pointer to a new position. 4. Release the mouse button.

Double-click: 1. Position the pointer on an object. 2. Press and release the mouse button twice, quickly.

Pull-down Menus: 1. Position the pointer on a menu title within the menu bar. 2. Press the mouse button and drag the pointer to the menu choice. 3. Release the mouse button.

When you play a Jam Session song, the menu bar at the top of the screen will disappear. When the song stops, or if the mouse button is pressed, the menu bar will reappear.

Hard Disk Installation

To install Jam Session on your hard disk simply copy all of the files from both Jam Session disks into one folder on your hard disk.

It's important that you also copy the file named Studio.24 into your System Fonts folder. This file is located on Jam Session Disk 1.
Let's Jam

Starting the Program

Your Jam Session package contains two disks. Follow these step-by-step instructions to start the program:

1. If your IIgs is connected to an external sound system, such as a stereo or portable cassette player, you should turn on that equipment, but make sure the volume is set at a low level.

2. With your IIgs turned off, insert the Jam Session “Disk 1” disk into Drive 1. Put the Jam Session “Disk 2” disk into Drive 2, if you have one. If you don’t have a second disk drive, you’ll have to load “Disk 2” disk later.

3. Turn on your IIgs. After a few seconds a window will appear with a list of file names. Click the Jam Session file name then click the Open button. After a few seconds an animated title screen will appear.

Setting the Volume and System Speed

To adjust the IIgs volume, access the IIgs Desk Accessories by pressing the Open Apple, Control and Esc keys simultaneously.

Using the arrow keys, select Control Panel, then select Sound and adjust the volume to the desired level. Press Return to get back to the Control Panel.

To make sure your system is operating at the fast speed, use the arrow keys to select System Speed and make sure it is set to Fast. Press return to get back to the Control Panel.

Select Quit at the Control Panel and Desk Accessories to return to the program.

Selecting a Song

Now we’re ready to jam! To play a new Jam Session song, select Open Song from the File menu. A window will appear displaying a list of files. Double-click on Songs to see the list of Jam Session songs.
If the window does not contain Songs, and if you don't have a second disk drive, eject the disk currently in the drive, insert the Jam Session "Disk 1" disk into the drive, and click on the Disk button.

If you have a second drive, insert the Jam Session "Disk 1" disk into the drive and click on the Disk button.

For demonstration purposes, find the song entitled Walkbass. Double-click on Walkbass to load it. If you just have one disk drive, the program may ask you to swap disks. Just follow the prompts on the screen, and click on the Okay button when you have inserted the proper disk.

To start the song, select Play from the Jam menu. You will first hear some audience applause and then music will start to play. If you don't hear anything, make sure your volume setting is at the appropriate level (see "Setting the Volume" above). If you've hooked-up your IIGs up to external amplification, make sure everything is properly connected.

If you want to stop the music, simply press the mouse button and the menu bar will reappear. To start the music again, pull down the Jam menu and reselect Play.

Once the music starts playing you can join in and "jam" by pressing any of the letter or number keys on the IIGs keyboard. Go ahead and try it!

In the song, "Walkbass," you'll notice that:

- The number keys play single piano notes.
- The row of keys starting with the letter "Q" play slow and medium piano riffs (a "riff" is a short musical passage or melody).
- The row of keys starting with the letter "A" play fast piano riffs.
- The bottom row of keys play drum fills.

For more variety, try pressing the same keys while holding down the
Shift key. Notice how the Shift key lets you play bass solos and a greater variety of drum fills. (If you want the Shift key down for a prolonged period of time you can simply press the Caps Lock key.

Feel free to experiment with all the keys. You can't make a mistake with Jam Session!

To get a better idea of what each key does, select Keyboard Index… from the Options menu. A window will appear displaying the musical functions for each row of keys, in addition to any special keys.

The top row of keys (the number keys) will usually be reserved for single note scales. Other rows of keys will usually have either slow riffs, fast riffs, percussion riffs or single note scales. Hold down the Shift key while viewing the Keyboard Index to see how the Shift key affects the keyboard layout.

Certain keys are reserved for special functions as follows:

• **Option**  
  Holding down the Option key together with certain repeating riff keys will cause the riffs to descend in pitch “chromatically” (a half step at a time).

• **Open Apple**  
  Holding down the Command key together with certain repeating riff keys will cause the riffs to ascend in pitch chromatically.

• **Space bar**  
  Pressing the Space bar will cause a riff to stop playing.

**Note:** The Delete, Return, Esc and Enter keys are inactive when the music is playing.
There are also special procedures that allow you to further customize your playing:

• Holding down certain riff keys will cause one note in the riff to sustain until you release the key.

• Holding down certain riff keys will cause the riff, or a portion of the riff, to repeat.

The appropriate key for the above procedures varies with the song you’re playing, so feel free to experiment!
Performance Features

Show Piano Keyboard

A piano keyboard reflecting the notes you play can be displayed at the bottom of the screen. If you want to have the keyboard shown, select Show Piano Keyboard from the Options menu. Once the keyboard appears, you can remove it by selecting Hide Piano Keyboard from the Options menu.

Set Song Length

Each Jam Session song is set to repeat or cycle a certain number of times which determines the overall playing time. By changing the number of cycles, you can shorten or lengthen a song.

To alter the length of a song in this manner, select Set Song Length... from the Options menu. When the window appears, type in a new number (of cycles) and click the Yes button.

Set Tempo

You can determine how fast or slow a song plays by selecting Set Tempo... from the Options menu. When the window appears, type in a new number from 10 to 450. The greater the number, the faster the song will play.

Atmosphere

If Atmosphere in the Options menu has a check mark next to it, you will hear applause at the start and end of each Jam Session song. By selecting Atmosphere you can toggle this feature off and on.

Sequence Riffs

Under normal conditions, most Jam Session riffs start to play when their key is pressed and stop playing when another key is pressed, or the riff finishes. If Sequence Riffs from the Options menu is selected, each key pressed will cause the corresponding riff to play in its entirety before the next riff begins. This allows you to sequence several riffs together by pressing their riff keys ahead of time, while the song is playing.

The presence of a check mark next to Sequence Riffs in the Options menu indicates that this option is currently turned on. Reselecting Sequence Riffs will toggle this feature off and on.
Sync to Measure

Under normal conditions, Jam Session riffs start to play whenever a key is pressed, without regard to the song’s rhythmic beat. To insure that every riff starts playing on beat, select Sync to Measure from the Options menu. While this feature is turned on, a riff won’t actually start playing until the beginning of the next musical measure, even though you may have pressed the riff key in the middle of the measure.

The presence of a check mark next to Sync to Measure in the Options menu indicates this option is currently turned on. To toggle this feature off and on, simply reselect Sync to Measure.

Auto Play

If you’d rather listen to Jam Session music instead of playing it, open a song and select Auto Play from the Jam menu. The program will then automatically start jamming by itself.

If Sync to Measure is turned on when you select Auto Play, it will affect the Auto Play riffs in the usual way.
Recording Features

Record

You can record your Jam Session performances by selecting **Record**, instead of **Play**, from the **Jam** menu. The song will begin and you can play along exactly as if you had selected **Play**, except that now the program will remember every key you press.

After the song is finished, or stopped manually, you can listen to your recording by selecting **Play** from the **Jam** menu.

Saving Your Recording

If you want to save your recording, have a formatted disk or a disk with free space handy and select **Save Song** from the **File** menu. You will have to save to a separate data disk because all the disks that come with Jam Session are loaded to their maximum capacity.

A window will appear on screen allowing you to indicate a new file name for your song.

If you have a single disk drive, remove the Jam Session disk from your drive. Then insert your data disk. If you have a second drive, you can switch to that drive for your data disk by clicking the Disk button.

Finally, click on **Save** after naming your song.

Once a recording has been saved, you can listen to it later by selecting **Open Song** from the **File** menu and loading the recording as you would any Jam Session song.

Erase

Select **Erase** from the **Jam** menu to clear all riffs that you recorded. This feature will not affect recordings that are saved on a data disk.
Editing Features

Editing Riffs

If you know how to read music and want to create your own riffs, Jam Session contains a simplified music editor that allows you to modify the existing riffs in each song. To edit a riff, start a song by selecting Play from the Jam menu and then play along normally (at least one riff must be played). At any point you choose, press the mouse button to stop playing. Now select Edit Riff... from the Edit menu and a musical staff will appear showing the notational representation of the last riff you played.

Editing riffs is done by using the four tools located in the Cursor Tool Box at the lower left corner of the edit window. These tools can be selected by pointing and clicking on them. There are four tools available: the Note Cursor, Rest Cursor, Bender Cursor and the Eraser Cursor.

Note Cursor: To place or insert a new note on the music staff, select the Note Cursor and then simply position that cursor on a specific staff line and click once. An eighth-note will instantly appear at that location.

To place a note of a different time duration, put the Note Cursor on the music staff, hold down the mouse button and drag the mouse to the right to increase the length of the note, or left to decrease the length. The note symbol will change accordingly. When the desired note length appears, simply release the button to place the note.

To adjust the pitch of a note in half-step increments, put the Note Cursor on the staff, hold down the mouse button and drag the mouse up or down to raise or lower the pitch. Release the button when the desired pitch appears.
**Rest Cursor**: To place or insert a rest, first select the **Rest Cursor**, then put the cursor anywhere on the staff and click once. An eighth-rest will instantly appear on the staff.

To place a rest of a different time duration, put the Rest Cursor on the music staff, and hold down the mouse button while dragging the mouse to the right to increase the length of the rest, or to the left to decrease it. The rest symbol will change accordingly. When the desired rest length appears, simply release the button.

**Bender Cursor**: The Bender Cursor works in much the same way as the Note Cursor and the Rest Cursor, except that instead of adding new notes and rests to the staff, the Bender Cursor is used to modify already existing notes and rests.

To modify the pitch of an existing note, select the **Bender Cursor**. If you position the Bender Cursor above or below a particular note and click the mouse, the note will shift up or down to the position of the Bender Cursor.

The Bender Cursor can also be used to change an existing note’s pitch in half-step increments by placing the cursor over a note, holding down the button and dragging the mouse up or down.

To modify the duration of a note or rest, place the Bender Cursor directly over it, and drag the mouse to the left or right while holding down the mouse button.

**Eraser Cursor**: To remove a note or rest from the staff, select the **Eraser Cursor**, move the cursor to the item you want to remove, and click once.

To listen to a riff while you are using the riff editor, click on the **Play** button in the upper left corner of the edit window.

**Instruments**: The currently assigned instruments for a particular riff
are shown in the vertical rectangles that are displayed on the music staff.

Instrument rectangles cannot be altered in the riff editor and the tools in the Cursor Tool Box will not affect them.

**Hold Note and Hold Repeat:** Some vertical rectangles on the music staff don't contain instrument names, but contain the words "Hold Note" or "Hold Repeat." These are special riff features which are activated by pressing and holding down a riff key during normal play of a song.

If a riff contains the **Hold Note** feature, the note immediately to the right of the Hold Note rectangle will sustain while the riff key is held down.

If a riff contains the **Hold Repeat** feature, the group of notes after a
repeat bar (double bar with four dots) and to the left of the Hold Repeat rectangle, will repeat while the riff key is held down. The number of repeats is indicated above the repeat bar. The Hold Repeat feature will not work unless there is also a repeat bar immediately to the right of the Hold Repeat rectangle.

**Triplets:** Some riffs contain notes with a small “3” above them. These are triplets and can be edited and placed on the staff like other notes.

**Editing Other Riffs:** While in the editor, you can edit additional riffs from the same song simply by hitting the desired riff key. The corresponding riff for the key you hit will appear in notational form in the edit window.

Because of the special way Jam Session songs are constructed, most riff keys have several different riffs assigned to them. When you press a key in a song, the particular riff you hear depends on which part of the song is currently playing. As a result, to edit all of the different riffs assigned to a particular riff key, you should play the song and then select the editor when you find the desired riff for that key.

For riffs that have multiple parts, hit the **Return** key to display the notes for each different part.

**Saving Your Changes:** When you are finished editing riffs select **Close** from the **File** menu. If you want to keep your changes for future playing, select **Save Song** from the **File** menu to save the song along with the edited riffs to a data disk.
If you don’t want to keep your changes, you can restore the original
riffs (and instruments, if any were changed) to the last saved version
simply by selecting Revert from the File menu.
The Jam Session Songs

Classical

Chopinjamski
Classical stylings on the ivories.

Jamoque
Jamming in the baroque style.

Mintsleeves
Variations on a traditional theme.

Country

Chicken Jamboree
Take your pick on this bluegrass breakdown.

Pickin' 'n Clickin'
Saloon-style country licks.

Jazz

Django Djam
Guitar jazz in the style of Django Reinhardt.

Two Hand Jazz
Night club piano stylings.

Walkbass
Medium tempo jazz-blues.

Miscellaneous

Happy Fingers
20's-style chase music.

Jambo
Drums and percussion.

BitMap Rap
Funky fingerings for your computer.

Nerdwalk
Lighthearted collection of sound.

Rock/Pop

Berry Jam
Classic rock 'n roll from the 50's.
Rock/Pop continued

Boogie Jam
Boogie-woogie piano licks.

Jamaica
Reggae jam complete with steel drums.

Jamtana
Hot Latin-style rock.

Metal Madness
Head banging craziness with lots of distortion.

Shuffle Off
Heavy blues-rock jam.

Studio Rock
Modern rock stylings.

Traffic Jam
Techno-pop rock.

All songs written by Ed Bogas, except JAMBO by Steve Mitchell METAL MADNESS by Edward Badasov and BITMAP RAP by Neil Cormia.
About the Authors

Ed Bogas
Ed has been a musician for most of his life, working primarily as a composer. He has scored dozens of movies, television shows, commercials and live shows. Recently, he worked on the Garfield television specials, and can be heard as the clucking chicken in the California Egg Board commercials. During the last few years he has been active in the microcomputer field, creating music and sound effects for various programs. Ed believes that microcomputer technology will help to make the creation of music a fun and easy process for everybody.

Steve Capps
Steve was part of the original Macintosh software team. He helped program the Finder and was “designated hitter” for the Mac ROM. Prior to his contribution on the Mac, he worked at Xerox doing computer research. Steve’s guidance and programming were instrumental to both Jam Session and the Studio Session project.

Neil Cormia
Neil has been a musician since he was 4 years old, and started programming computers at age 11. He is proficient on the saxophone, flute, piano and various Apple computers, but can’t decide which he likes best. Prior to producing Jam Session, Neil helped to program Studio Session. He is a graduate of the SCSP, class of ‘87.

Ty Roberts
Ty started programming the Apple II in 1980 and also programmed video games for Milton-Bradley in the early days of cartridge games. Ty’s first major Mac project was Studio Session and, like Neil, is a graduate of the SCSP, class of ‘87.
Warranty Information

**Brøderbund's Limited Ninety-Day Warranty**

Brøderbund warrants for a period of ninety (90) days following the original retail purchase of this copy of *Jam Session* that the program is free from substantial errors or defects that will materially interfere with the operation of the program as described in the enclosed user documentation. This policy applies to the initial purchaser only.

If you believe you have found any such error or defect in the program during the warranty period, call Brøderbund's Technical Support Department at 415/492-3500 between the hours of 8 a.m. and 5 p.m. (Pacific Time), Monday through Friday. Brøderbund technical personnel will attempt to help you correct or avoid the problem. If any such error or defect cannot be corrected or reasonably avoided, Brøderbund will inform you how to obtain a corrected program disk (or, at Brøderbund's option, Brøderbund may authorize a refund of your purchase price).

This warranty gives you specific legal rights, and you may also have rights which vary from state to state.

**Disk Replacement Policy**

If any disk supplied with this product fails within ninety (90) days of purchase for any reason other than accident or misuse, please return the defective disk together with a dated proof of purchase to Brøderbund Software Direct®, 17 Paul Drive, San Rafael, CA 94903 2101, for a free replacement. This policy applies to the original purchaser only.

Brøderbund will replace program disks damaged for any reason, whether during or after the ninety (90) day free replacement period, for $5 per disk plus a postage and handling charge of $2.50 per request, as long as the program is still being manufactured by Brøderbund.

Unauthorized representations: Brøderbund warrants only that the program will perform as described in the user documentation. No other advertising, description or representation, whether made by a Brøderbund dealer, distributor, agent or employee, shall be binding upon Brøderbund or shall change the terms of this warranty.
Limitations on Warranty

IMPLIED WARRANTIES LIMITED: EXCEPT AS STATED ABOVE, BRØDERBUND MAKES NO OTHER WARRANTY, EXPRESS OR IMPLIED, REGARDING THIS PRODUCT. BRØDERBUND DISCLAIMS ANY WARRANTY THAT THE SOFTWARE IS FIT FOR A PARTICULAR PURPOSE, AND ANY IMPLIED WARRANTY OF MERCHANTABILITY SHALL BE LIMITED TO THE NINETY (90) DAY DURATION OF THIS LIMITED EXPRESS WARRANTY AND IS OTHERWISE EXPRESSLY AND SPECIFICALLY DISCLAIMED. SOME STATES DO NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

NO CONSEQUENTIAL DAMAGES: BRØDERBUND SHALL NOT BE LIABLE FOR SPECIAL, INCIDENTAL, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF BRØDERBUND IS ADVISED OF OR AWARE OF THE POSSIBILITY OF SUCH DAMAGES. THIS MEANS THAT BRØDERBUND SHALL NOT BE RESPONSIBLE OR LIABLE FOR LOST PROFITS OR REVENUES, OR FOR DAMAGES OR COSTS INCURRED AS A RESULT OF LOSS OF TIME, DATA OR USE OF THE SOFTWARE, OR FROM ANY OTHER CAUSE EXCEPT THE ACTUAL COST OF THE PRODUCT. IN NO EVENT SHALL BRØDERBUND'S LIABILITY EXCEED THE PURCHASE PRICE OF THIS PRODUCT. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU.

You are entitled to use this product for your own use, but may not sell or transfer reproductions of the software or manual to other parties in any way, nor rent or lease the product to others without the prior written permission of Brøderbund. You may use one copy of the product on a single terminal connected to a single computer. You may not network the product or otherwise use it on more than one computer or computer terminal at the same time.

For technical support, on this or any other Brøderbund product, call 415/492-3500.